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I - FundamentalsI - Fundamentals

o Code development strategies
? The challenge
? Traditional solution
? Our solution
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“Traditional” solution“Traditional” solution
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High level language as a scripting environmentHigh level language as a scripting environment
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Writing an applicationWriting an application
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oo High level codingHigh level coding
oo Code re-useCode re-use
oo ExtensibleExtensible
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Why Python ?Why Python ?

o Object-Oriented Tcl, Perl, C, …

o Advanced data structures Tcl, Perl

o Powerful data-parallel arrays Tcl

o Readability and modularity Perl

o High-level C, C++, Fortran

o Platform independence C, C++, Java, …

o Interpreted C, C++, Java, …

Our language needed : Not met by :

Python based molecular softwarePython based molecular software

o Chimera : UCSF - Computer Graphics Lab.
http://www.cdl.ucsf.edu/chimera

o MMTK : CNRS - Institut de Biologie Structurale
http://starship.python.net/crew/hinsen/mmtk.html

o Pymol : Delano Scientific.
http://www.pymol.org

o PyDayLight : Daylight Chemical Information Systems, Inc.
http://starship.python.net/crew/dalke/PyDaylight/

o MDTools : UIUC - Theoretical Biophysics Group.
http://www.ks.uiuc.edu/~jim/mdtools/

o ...

I - FundamentalsI - Fundamentals

o Python primer
? Python installation
? Language characteristics
? Basics
? Standard library
? Extending Python
? Numeric extension
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Python installationPython installation
1- Open the demoNPACI folder on your desktop

2- Double click on              icon to start the

installation of Python.
3- Follow the installation instructions:

? Use default settings for steps 1 through 5
? Step 6 Install Tcl/Tk : YES
? Use default settings for the remaining steps.

4- In C:\Program Files\Python:

Python.exe

starts a Python interpreter
Double click

Py152.exe

Language characteristicsLanguage characteristics

o Interpreted, high level, object-
oriented

o Flexible and extensible
o Introspection, self-documenting
o Platform independent
o Open-source
o Rapidly gaining acceptance

BasicsBasics

>>> a = 2               # integer
>>> b = 7.5            # float
>>> c = ‘hello’        # string
>>> d = “ World!”  # string too
>>> # this is a comment
>>> print c+d
>>> print “sum :”, a+b

- No Memory allocation
- No variable declaration

- simple and intuitive
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List - mutable sequencesList - mutable sequences

>>> lst = [2, 1,‘hello’]

>>> lst.append(5)

>>> lst.remove(1)

>>> lst.insert(1,’Paul’)

>>> lst.sort( )

lst contains:

[2, 1,‘hello’]

[2, 1, ’hello’, 5]

[2,’hello’,5]

[2,’Paul’,’hello’,5]

[2,5,’Paul’,’hello’]

Tuple Tuple - immutable sequences- immutable sequences

>>> tup = (1,2,’spam’)
# automatic packing and unpacking

>>> tup = 1,2, ‘spam’

>>> a,b,c = tup

>>> print a, b, c
# correct singleton syntax

>>> tup = (1,)

>>> tup[0] = 6

(1, 2, ‘spam’)

(1, 2, ‘spam’)

1 2 ‘spam’

# ERROR : cannot assign value in a immutable sequence !

(1,)

tup contains:

Sequences indexing and slicingSequences indexing and slicing

>>> lst = [1,’b’,6,’a’,8,’e’]

>>> lst[2:4]
>>> lst[2:-2]
>>> lst[-4:-2]

- Indexing : lst[i]

1 ‘b’ 6 ‘a’ 8 ‘e’
-1-2-3-4-5-6

0 1 2 3 4 5

- Slicing : lst[from:to]

i1 ‘b’ 6 ‘a’ 8 ‘e’
-1-2-3-4-5-6

0 1 2 3 4 5
>>> lst[4]
>>> lst[-2]

1 ‘b’ 6 ‘a’ 8 ‘e’
-1-2-3-4-5-6

0 1 2 3 4 5
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ExerciseExercise

In the Python interpreter:

1- Create a list l1 containing the following

elements: 1, 2.6, ’b’, 7, 9, ’z’

2- Assign a new value to the 3rd element of l1?

3- If l2 = l1[1:-2] guess the elements contained

in l2.

SolutionSolution

>>> l1 = [1, 2.6, ‘b’, 7, 9, ‘z’]
>>> l1[2] = ‘new’
>>> print l1
[1,2.6,’new’, 7, 9, ‘z’]
>>> l2 = [1:-2]
>>> print l2
[2.6,’new’, 7]

DictionaryDictionary

>>> dict = { ‘Marc’:25, 30 : ‘Jim’ }
>>> dict[5.7] = ‘joe’

# Accessing the information

>>> dict.items()

>>> dict.values()

>>> dict.keys()

>>> dict.has_key(‘Marc’)

[(‘Marc’,25), (30,'Jim'), (5.7,’joe’ )]

[ 25,’Jim’, ‘joe’]

[‘Marc’, 30, 5.7]

True

 dict = { key1 : value1 , key2 : value2, ...}

item1

{ ‘Marc’:25, 30:’Jim’, 5.7: ’joe’ }
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Control flowControl flow
o While :

>>> b = 0
>>> while b < 5:
. . .          print  b; b=b+1
0 1 2 3 4  

o If :
>>> q = ‘Please Enter a number'
>>> x = int( raw_input (q) )
>>> if x == 0:
. . .       print ‘x equals 0’
. . . elif x < 0:
. . .        print ‘ x is negative’
. . . else:
. . .        print ‘x is positive’

o For, range(), break, continue :
>>> seq = range(-3, 4, 1)
>>> print seq
[-3,-2,-1,0,1,2,3]
>>> for s in seq:
. . .       if s < 0:
. . .             continue
. . .       else:
. . .             print s
0,1,2,3

Functions and argumentsFunctions and arguments

def func( a, b, n1=10, n2=‘hello’ ):

Positional arguments (required)

Named arguments (optional)Function name

>>> func( 2, 'string', 3.14 )
>>> func( 7.2,  'string',  n2=15)
>>> func( 'hello', 2 , 5, ’bye’)
>>> func( n1 = 5 )
>>> func( n1=12, 3.14 )

Argument matching:

    2    'string' 3.14 'hello'
  7.2   'string'  10      15
'hello'    2         5    'bye'

a          b        n1      n2

ERROR: missing argument
ERROR: positional argument after
             named argument

Functions - Functions - Arbitrary argumentsArbitrary arguments

def func( *args, **kw)

Combining the two argument passing methods

>>> def func( a, b, f=10, *args, **kw):

Tuple of positional
arguments

Dictionary of named
arguments

>>> func( 2, 'string' , n1 = 5, n2 = ‘a’ )

Argument matching: args kw

(2,’string’ ) { ‘n1’ : 5, ’n2’ : ’a’ }
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Classes - basicsClasses - basics

class Rectangle:
     def __init__(self, width, length): # Constructor
          self.w = width                          # instance attribute
          self.l = length                          # instance attribute

# call the constructor to create an instance
rect1 = Rectangle( 5, 6 )
# create another instance
rect2 = Rectangle( 4, 2 )
# access instance's attributes
print rect1.w, rect1.h                       5 6
print rect2.w, rect2.h                      4 2

Classes - methodsClasses - methods

class Rectangle:
     def __init__(self, width, length): # Constructor
          self.w = width                          # instance attribute
          self.l = length                          # instance attribute
    def area(self):                              # method area
          return self.w * self.l

# call the constructor to create an instance
rect1 = Rectangle( 5, 6 )
rect2 = Rectangle( 4, 2 )
# calling a method
print rect1.area( )                                        30
print rect1.area( ) + rect2.area( )                 38

Classes - overwriting operatorsClasses - overwriting operators

class Rectangle:
     def __init__(self, width, length): # Constructor

          self.w = width                          # instance attribute
          self.l = length                          # instance attribute

     def __add__(self, right):             # defines rect1+rect2

 def __mult__(self, right):           # defines rect1*rect2

 def __repr__(self ):                    # defines print(rect1)

      def __call__(self, *args, **kw):  # define rect1('hello')

      etc ...
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ModulesModules
The file MyModule.py contains:
def func1(b):

print ‘You called func1 with b = ’,b

>>> import MyModule
>>> dir(MyModule)
[‘__builtins__’,’__doc__’,’__file__’,’__name__’,func1]
>>> MyModule.func1(10)
You called func1 with b = 10

>>> from MyModule import func1
>>> func1(10)
You called func1 with b = 10

>>> from MyModule import *
>>> func1(10)
You called func1 with b = 10

ExerciseExercise

1- Open in emacs the file myModule.py located in

the demo folder.

2- Extend the class Rectangle with a method to

compute the perimeter.

3- Start a Python interpreter. Import the class

Rectangle from the package myModule.

4- Create an instance rect1 of that class.

SolutionSolution
class Rectangle:
     def __init__(self, width, length): # Constructor

          self.w = width                          # instance attribute
          self.l = length                          # instance attribute
    def area(self):                              # method area
          return self.w * self.l
    def perimeter(self):          # method perimeter
          return 2*(self.w + self.l)

>>> from MyModule import Rectangle        #  importing the class Rectangle
>>> rect1 = Rectangle(7,3)                         # creating an object rect1
>>> per = rect1.perimeter()     # calling the new method.
>>> print per
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Packages - organizing modulesPackages - organizing modules

>>> import sys
>>> print sys.path   # print the Python path
[ 'dir1', 'dir2', 'dir3', …. ]

subdir1:
     __init__.py
     foo.py:
          def Func(a,b):
               ….
          class Object:
               …

subdir2:
      data.txt
      bar.py

Makes subdir1 a package

subdir2 is NOT a package, bar.py
CANNOT be imported

from subdir1 import foo
from subdir1.foo import Func
from subdir1.foo import Object

Standard librariesStandard libraries

sys, os, string, math, cgi, commands, shelve
etc…
Example:

>>> import sys
>>> path = sys.path
>>> print path[:3]
[ ‘ ‘, ‘C:\\Program Files\\Python’, ‘ C:\\ Program

Files\\Python\\Lib\\plat-win’]

Extending PythonExtending Python

Add functionality to Python
Gaining access to legacy code
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Extending PYTHONExtending PYTHON

LEGACYLEGACY
C, C++C, C++

FORTRANFORTRAN

ImplementImplement WrapWrap

NEWNEW
MODULEMODULE

Platform independentPlatform independent
PortabilityPortability

Platform dependentPlatform dependent
speedspeed

Wrapping C codeWrapping C code

#include "MyLib.h"
...
PyObject *fact_w(PyObject *obj)
{
  int n = PyGetInt(obj);
  int res = fact (n);
  PyObject *Pyres = PyMakeInt(res)
  return Pyres;
}
...

extern int fact(int i);

MyLib.h

/* Compute factorial of n */
int fact(int n) {
  if (n<=1) return 1;
  else return n*fact(n-1);}

MyLib.a

MyLibModule.so

SWIG

>>> import MyLib
>>> a = 5
>>> MyLib.fact(a)

Numeric extensionNumeric extension

Efficient storage and manipulation  of
large arrays of data.
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ConceptsConcepts

In C :

In Python:

import Numeric
ar = Numeric.array( [(1,5,5,9),
                                 (-2,3,4,26),
                                 (1, 2, 3, 7) ])
print ar.shape                       (3,4)
print ar.typecode()                 'l'
print ar.iscontiguous()            '1'

PyArrayObject
    void *data
    int *shape
    char typecode

 

1 5 5 9

m
n 

ReshapingReshaping

1  2  3
4  5  6

>>> B = Numeric.array([ [1,2,3],[4,5,6] ])

Numeric.reshape(B,(3,2))

shape (2, 3)

1  2
3  4
5  6

(3, 2)

1  2  3
4  5  6

Numeric.reshape(B,(-1,))

(2,3)

1  2  3  4  5  6

(6,1)  or (6,)shape

Indexing & SlicingIndexing & Slicing

>>> B = Numeric.array( [ [1,2,3],[4,5,6],[7,8,9] ])

1 2 3

4 5 6

7 8 9

row
col

0 1 2

0

1

2

B[1, 0]
element

B[0, :]
row

B[1:3, 1]
column
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Element-wise operationsElement-wise operations
Element-wise operation at C speed !

bop
4
5
6

=
1
2
3

4
5
6

bop
bop
bop

1
2
3

bop =
1
2
3

2
2
2

bop
bop
bop

1
2
3

bop
4
5

2 same as 
1
2
3

bop 2

binary operators (bop) : +, x, /, - ,% , power ...
unary operators (uop) : sin, cos, sqrt ...

1
2
3

uop
uop
uop
uop

1
2
3

=
1
2
3

Universal functions.Universal functions.

The most common Numeric universal functions:
take,transpose, repeat, choose, ravel,
nonzero,where, compress, diagonal, trace,
searchsorted, sort, argsort, argmax, fromstring,
dot, matrixmultiply, clip,indices, swapaxes ,
concatenate, innerproduct, array_repr, array_str,
resize,diagonal, repeat, convolve, where, identity,
sum, cumsum , product,cumproduct, alltrue,
sometrue…..

II -II - PMV PMV

o Fundamentals
o Commands
o Specialized extension: ADT
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Installing PMVInstalling PMV

1- Open the demoNPACI folder on your

desktop.

2- Double click on            icon to install PMV.

3- Open the demo directory and double click

on              to start PMV. 

Setup.pywsetup

Pmv.pywpmv

  An extensible and customizable application.An extensible and customizable application.

o Load commands on the fly :
loadCommand & loadModule commands.

? Loading the readPDB commands and the
displayCommands module.

File -> loadCommand -> fileCommands -> readPDB

File -> loadModule -> displayCommands -> Load Module

? Exercise:
1- Load the “deleteMol” command from the

deleteCommands module.

2- Load the “colorCommands” module.

Basic interaction with the viewerBasic interaction with the viewer

Rotation

XY Translation

 Z Translation 

Picking

Scaling

Action
Mouse
button Modifier

Right

Right

Right

Right

Left

Alt

Control

Shift
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An extensible and customizable application.An extensible and customizable application.

o Define Commands to be applied to molecule when
loaded: onAddObjectCommand
? Loading a molecule displayed as lines.

File -> OnAddObjectCommand -> buildBondsByDistance ->
displayLines -> Dismisss

! The order in which the commands are selected is the order in which
the commands are applied to the molecule.

File -> Read PDB -> 1crn.pdb -> Open

? Exercise:
Load a new molecule to be displayed as cpk and colored by
residue type.

An extensible and customizable applicationAn extensible and customizable application

o User preferences:
? SetUserPreference command.

Set for the current session
Made as default for the following sessions

o Customization of the GUI
? Customize command.

An extensible and customizable application.An extensible and customizable application.

o User specific customization files .pmvrc:
1- Open the .pmvrc in emacs

Right click on the .pmvrc file and send to

‘emacs’
2- Start a customized Pmv  session:

Double click on the             icon to start a new
Pmv session.

3- Load molecules:
Load the protease displayed as lines.
Load the indinavir displayed as cpk and colored by atom
type.

Setup.pywpmvcustom
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Working with PMVWorking with PMV

o Interactive Commands:
? Bind a Command to a mouse picking event.
? For applying the same command to multiple

subsets of atoms.

Altering the representation of subsets of atoms:
ICOM -> displaySticksAndBalls -> ICOM level -> Residue

Working with PMVWorking with PMV

o Undo Command:
? Undo commands stack
? User preference to set the number of

undo.
? The “Delete Molecule” command voids

the undo stack.

File -> Undo “last command executed”

Working with PMVWorking with PMV

o “Regular Commands”:
? Define the current selection:
? Apply multiple commands to the same current

selection.

o Current selection
? homogeneous
? empty -> everything is selected
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Working with PMVWorking with PMV

o Create a selection of Atoms:
ICOM -> select -> Atom -> pick and drag
select in the viewer.

o Change to a selection of Residues:
Icom level Residue.

o Save the current selection as a set:
Select -> Save current selection as a set ->

set1 -> OK -> Clear selection.

Working with PMV.Working with PMV.

o Retrieve the saved selection:
Select -> Select a set -> set1 -> OK

o Color the selection by atom type and
display as sticks and balls.
Color -> by Atom Type -> lines -> OK
Un/Display -> sticks and balls -> OK

Surfaces, Ribbons, etc...Surfaces, Ribbons, etc...

o Compute the molecular surface of the protease
and alter its representation:
Clear Selection
File -> Load Module -> msmsCommands -> Dismiss
Select -> Select From String -> Molecule List … ->
protease -> Select -> Dismiss
Compute -> Msms For Molecule -> density = 2.0 -> OK
Color -> by Residue Type -> Rasmol -> msms -> OK
Clear selection.

And more ….
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Working with PMV at a higher levelWorking with PMV at a higher level

o Exercise:
Represent the protease with a standard
Ribbon diagram colored by chains.

And more ….

Cool stuffs ...Cool stuffs ...

o Color the surface of the ligand by the
closest distance to protease.

o Magic lens.

Application design featuresApplication design features

o Dynamic loading of commands
o Python shell for scripting
o Dual interaction mode (GUI/Shell)
o Lightweight commands: Macros
o Command logging
o Dynamic commands (introspection)
o User-preferences / customization
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Application design features (cont'd)Application design features (cont'd)

o Load multiple molecules
o Hierarchical representation of

molecules
o Create/Select homogeneous sets
o Current selection concept
o Commands apply to current selection
o Interactive commands

II -II - PMV PMV

o Commands
? Create, delete, write molecules
? Selection
? Basic representations and coloring
? Advanced representations
? Editing molecules
? …

Create, delete, write moleculesCreate, delete, write molecules

o Create:
? PDBReader
? Mol2Reader
? PDBQReader
? PDBQSReader
? PQRReader
? GeneralReader

o Delete
? deleteMol

o Write
? PDBWriter
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SelectionSelection

o  From string
o  By picking

?  molecule, chain, residue, atom
o  By distance
o  Displayed lines or cpk
o  Invert selection
o  On chain
o  ...

Basic representations and coloringBasic representations and coloring

o Display by:
? lines
? cpk
? sticks and balls
? ...

o Label:
? by properties

o Color geometries by:
? atom type
? residue type

shapely, Rasmol, N to C
? chains
? molecules
? properties
? secondary structure

type
? ...

Advanced representationsAdvanced representations

o MSMS molecular surface
? compute & display :

o MSMSMol
o MSMSSel

o CA trace:
? compute
? extrude
? display

o Spline:
? compute
? display

o Secondary Structure:
? get SS information:

o from file
o from stride

? extrude
o default (rectangle,

circle)
o circle
o rectangle
o ellipse
o ...

? display



22

Editing moleculesEditing molecules
o AIDE Module:
( pyBabel: reimplementation of some of
the Babel v1.6 functionalities)

? atom type assignment
? gasteiger charges calculation
? atom type conversion
? rings detection
? bond order assignment
? aromaticity detection
? hydrogen atoms addition

III - III - From Building Blocks to applicationsFrom Building Blocks to applications

o MolKit
o DejaVu
o ViewerFramework
o Putting it all together
o Writing a simple command

III - III - From Building Blocks to applicationsFrom Building Blocks to applications

o MolKit
? Hierachical data-structure
? TreeNodes and TreeNodeSets
? Derived classes
? Parsers
? Examples
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HierachicalHierachical data-structure data-structure

NumericNumeric

MolKitMolKitTreeNode

.parent

.children

...

TreeNode

adopt(child)
TreeNodeSet(ListSet)

[TreeNode, TreeNode, … ]

.top

.elementType

TreeNode

HierachicalHierachical structure (cont'd) structure (cont'd)

node = TreeNode()
node.newMember = myvalue

- dynamic adding of
   new members

- TreeNodeSet slicing 
   and indexing

- shortcut to access
   children's members

- multi-level hierachy

node.children[5]
node.children[10:25]

node.children[0].children[-1]

- building trees 
   by adoption

parent = TreeNode()
child = TreeNode()
parent.adopt(child)

print node.children.name
[ 'NoName' , 'NoName', 'NoName',...]

TreeNodeTreeNode, , TreeNodeSetTreeNodeSet

o TreeNodeSet:
? Boolean operation
? uniq( )
? split( )
? sort( )
? NodesFromName( )
? findChildrenOfType( )
? findParentOfType( )
? …

o TreeNode:
? adopt( ) / remove( )
? full_name( )
? NodeFromName( )
? split( ) / merge( )
? getParentOfType( )
? findType( )
? compare( )
? assignUniqIndex( )
? isAbove( ) / isBelow( )
? …
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TreeNode TreeNode and and TreeNodeSet TreeNodeSet specializationspecialization

Residue Chain Protein ...

Molecule Atom

Helix Strand Turn Coil

SecondayStructure ...

TreeNode

ResidueSet ChainSet ProteinSet ...

MoleculeSet AtomSet

HelixSet StrandSet TurnSet CoilSet

SecondayStructureSet . . .

TreeNodeSet

ParsersParsers

PDB
Mol2
PQR
...

Parser

MoleculeSet from MolKit .pdbParser  import PdbParser
parser = PdbParser(‘1crn.pdb’)
mols = parser.parse( )

PDB parser MOL2 parser
Molecule

Chain

Residue

Atom

Molecule

Chain

Residue

Atom

Molecule

Residue

Atom

Molecule

Atom

ExamplesExamples
>>> from  MolKit import  Read
>>> molecules = Read(‘./1crn.pdb’)
>>> mol = molecules[0]             # Read returns a ProteinSet

>>> print mol.chains.residues.name
>>> print mol.chains.residues.atoms[20:85].full_name()

>>> from MolKit .molecule import Atom
>>> allAtoms  = mol. findType(Atom)
>>> set1 = allAtoms.get(lambda x: x.temperatureFactor >20)

>>> allResidues = allAtoms .parent.uniq()
>>> import  Numeric
>>> for r in allResidues:
. . .     coords = r.atoms.coords
. . .     r.geomCenter = Numeric.sum(coords) / len(coords)
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III - III - From Building Blocks to applicationsFrom Building Blocks to applications

o DejaVu
? Overview
? Features
? Geometries
? DejaVu and MolKit

OverviewOverview

TkinterTkinter

NumericNumeric
PyOpenGLPyOpenGL

DejaVuDejaVu

DEMODEMO

from DejaVu import Viewer
vi = Viewer( )
from DejaVu.Spheres import Spheres
centers = =[[0,0,0],[3,0,0],[0,3,0]] 
s = Spheres(‘sph’, centers = centers)
s.Set(quality=10)
vi.AddObject(s)

Demo CodeDemo Code

>>> from DejaVu import Viewer
>>> vi = Viewer( )

>>> from DejaVu.Spheres import Spheres
>>> centers = =[[0,0,0],[3,0,0],[0,3,0]]
>>> s = Spheres(‘sph’, centers = centers)
>>> s.Set(quality=10)

>>> vi.AddObject(s)
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FeaturesFeatures

o OpenGL Lighting and Material model
o Object hierarchy with transformation and

rendering properties inheritance
o Arbitrary clipping planes
o Material editor
o DepthCueing (fog), global anti-aliasing
o glSscissors/magic lens
o Multi-level picking
o Extensible set of geometries

GeometriesGeometries

Geom

o PolyLine
o Points
o Spheres
o Labels
o Arc3D...

IndexedGeoms

o IndexedPolyLines
o IndexedPolygoms
o Triangle_Strip
o Quad_Strip
o Cylinders ….

DejaVu DejaVu and and MolKitMolKit
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Demo CodeDemo Code

>>> from  MolKit import Read
>>> molecules = Read(‘./1crn.pdb’)
>>> mol = molecules[0]   # Read returns a ProteinSet

>>> coords  = mol.chains.residues.atoms.coords
>>> radii = mol.defaultRadii()

>>> sph = Spheres(‘sph’ , centers = coords, radii = radii,
                  quality=10)

>>> vi.AddObject(sph)

III - III - From Building Blocks to applicationsFrom Building Blocks to applications

o ViewerFramework
? Overview
? Design features
? Implementation

OverviewOverview

NumericNumeric
PyOpenGLPyOpenGL TkinterTkinter

DejaVuDejaVu

IdleIdle

ViewerFrameworkViewerFramework
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Design featuresDesign features

o Dynamic loading of commands
o Python shell for scripting
o Dual interaction mode (GUI/Shell)
o Support for command:

? development, logging, GUI, dependencies
o Lightweight commands: Macros
o Dynamic commands (introspection)
o Extensible set of commands

ImplementationImplementation

GeomContainer

VFGUI

VFCommandsGUIGUI
commands
objects
userpref

UserPreference

addObject( … )
removeObject( … ) 
addCommand( … )
askFileOpen( … )
askFileSave( … )
getUserInput( … )

VFCommand

Objects

 

ViewerFramework

 
 

 

III - III - From Building Blocks to applicationsFrom Building Blocks to applications

o Putting it all together:
? Specializing ViewerFramework
? MolKit in PMV
? DejaVu in PMV
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Specializing Specializing ViewerFrameworkViewerFramework
ViewerFramework

geomContainer

molGeomContainer

PMV

VFCommand
  . vf

MoleculeViewer
  .Molecules

ViewerFramework
  .Objects

MVCommand
   .getNodesByMolecules (nodes)
    .vf

 

 

 

 

 

Specializing Specializing ViewerFramework ViewerFramework (cont'd)(cont'd)

VFCommand
ShellCommand

loadCommandCommand

ExitCommand

helpCommandCommand

Etc...

MVCommand

PDBReader

MoleculeLoader

Mol2Reader

DisplayLines

Etc...

ViewerFramework
PMV

PMVPMV Architecture Architecture

NumericNumeric

PyOpenGLPyOpenGL TkinterTkinter

DejaVuDejaVu
IdleIdle

ViewerFrameworkViewerFramework

PynchePynche

PmvPmv

MolKitMolKit
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MolKit MolKit inin PMV PMV

>>> print mv.Mols
<MoleculeSet instance> holding 2 Protein

>>> mv.Mols[0]
<Protein instance> 1crn with 1 MolKit.protein.Chain

>>> from MolKit.protein import Residue
>>> residues = mv.Mols.findType(Residue)
>>> residues
<ResidueSet instance> holding 154 Residue

>>> residues.myIndex = range(len(residues))
>>> residues[1:10].myIndex
[1,2,3,4,5,6,7,8,9]

DejaVuDejaVu in in PMV PMV
>>> # access to DejaVu features from the pyShell

>>> vi = mv.GUI.VIEWER
>>> camera = vi.cameras[0]
>>> camera.Set( color=(1.,1.,1.) )
>>> vi.Redraw()

>>> # show the Viewer's original GUI
>>> vi.GUI.root.deiconify( )

>>> # hide the Viewer's original GUI
>>> vi.GUI.root.withdraw( )

III - III - From Building Blocks to applicationsFrom Building Blocks to applications

o Writing a simple command
? MVCommand overview
? Subclassing MVCommand
? Loading the command
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MVCommand MVCommand overviewoverview

    def __call__(self, *args, **kw):
        apply( self.doitWrapper , args, kw)

   def doit(self, *args, **kw):
       pass

    def guiCallback(self,  *args, **kw):
        apply( self.doitWrapper , args, kw)

class MyCommand(MVCommand):

    def doitWrapper(self, *args, **kw):
        self.beforeDoit()
         self.vf.tryto (apply(self.doit,args,kw))
         self.afterDoit()

Subclassing MVCommandSubclassing MVCommand
from Pmv.mvCommand import MVCommand
class MyReader(MVCommand):

def guiCallback(self):
    fTypes = [( 'PDB file','*.pdb'), ('PDBQ file','*.pdbq'),
                    ( 'MOL2 file','*.mol2')]

filename = self. vf.askFileOpen(types=fTypes ,
   title=‘Choose molecule file’)

val[‘redraw’]=1
mol = apply(self.doitWrapper , (filename, ), val)
return mol

def __call__(self, filename, **kw):
if not kw.has_key(‘redraw’): kw[‘redraw’]=1
apply(self.doitWrapper, (filename, ) , kw)

def doit (self, filename):
from MolKit import Read

     molecules = Read(filename)
     for mol in molecules:  self.vf.addMolecule(mol)

Loading the commandLoading the command

mv.addCommand( MyCommand(), 
‘myCommand’,

MyCommandGUI )

Instance of a Command

Instance of a CommandGUI :
describes the GUI associated
with a command (radiobutton,
checkbutton , menu entry ...)

Command name
in PMV.
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ExampleExample

>>> from Pmv.myCmd import MyReader
>>> from ViewerFramework.VFCommand import CommandGUI

>>> # Create a menu entry GUI for the command MyReader
>>> MyReaderGUI = CommandGUI()

>>> # Add the GUI to the menuRoot in the File menu
>>> MyReaderGUI.addMenuCommand(‘menuRoot’, ‘File’,
                                                         ’Read File …’,index=0)

>>> # add the command with its associated GUI, and name to PMV
>>> mv.addCommand(MyReader(), ’myread’, MyReaderGUI)

DEMODEMO

ConclusionConclusion

o Validity of the approach
o Python
o Availability
o Future directions

Validity of the approachValidity of the approach

o Set of components
? extensible
? inter-operable
? re-usable
? short development cycle

o User base expanding beyond our lab.
o Components re-use outside the field

of structural biology
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PythonPython

o Appropriate language for this approach
? modularity, extensibility, dynamic loading,

object-oriented, virtually on any platform, many
extensions from third party

o Rapidly growing community of programmers
using Python for biological applications

o Short comings
? reference counting, distribution mechanism, no

strong typing

AvailabilityAvailability

o Modularity enables fine grain
licensing schemes (a la carte)

o Core modules are freely available

o Online Download site:
http://www.scripps.edu/~sanner/Python

Future directionsFuture directions

o Add support for editing molecular
structures (i.e. mutations, deletion,
addition)

o Interface with MMTK, Tinker, ….
o Enhance documentation and tutorials
o Setup a CVS server for programmers

wanting to help !
o Too many to list ….
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